Client-Side Image Map Editor

A Standalone Java Application

Version 1.0

Released July 13, 1997

by Michael Y. Chiang

E-mail: myc@wwa.com

http://miso.wwa.com/~myc/csime/


Disclaimer: Please use at your own risk. The author is not responsible for loss of data, hardware malfunction, etc. Please backup your HTML files and use copies with this application.


Contents


Instructions

  1. You must have a Java Runtime Environment (JRE), Sun JDK (1.0.2 or greater), or equivalent (e.g., Symantec Cafe, Metrowerks Codewarrior) for your UNIX, Macintosh, Windows, etc. platform in order to run this Java standalone application.
  2. Download, unpack, and execute the Java class files.
  3. The main() method is inside the csime.MainShell class.

UNIX Example (csh)

% mkdir javaapps
% cd javaapps
% zcat csime.tar.Z | tar xvf -
% setenv CLASSPATH /home/myc/javaapps
% java csime.MainShell 

UNIX Example Running Directly From Zip File (csh)

With the Sun JDK 1.1, the application can be run directly from the csime.zip file without unzipping. Just add the file name to your class path in the environment or as a command line argument.

% java -classpath /usr/local/jdk1.1/lib/classes.zip:/home/myc/csime.zip csime.MainShell

Windows Example

  1. Uncompress using a utility like WinZip that preserves long filenames. Extract into a new directory on the C: drive called javaapps.
  2. Go to MS-DOS prompt.
    > set CLASSPATH=C:\javaapps
    > java csime.MainShell
        

Tested Platforms

At this time, the application has been tested on the following platforms:

The application has been tested by other users on the following platforms:


User Instructions

Inside the Editor Canvas

Link URL

File Menu

New...
Create a new image map.
Open...
Open an image map from an HTML text file.
Save
Save an image map to a previously specified HTML text file.
Note: THE EDITOR ONLY SAVES HTML TAGS RELATED TO THE IMAGE MAP ITSELF. ALL OTHER TAGS READ DURING OPEN OR IMPORT WILL BE LOST.
Save As...
Save an image map to an HTML text file.
Note: THE EDITOR ONLY SAVES HTML TAGS RELATED TO THE IMAGE MAP ITSELF. ALL OTHER TAGS READ DURING OPEN OR IMPORT WILL BE LOST.
Load Image File...
Load a GIF or JPEG image from a file.
Load Image URL...
Load a GIF or JPEG image from a URL.
Import...
Client-Side Image Map File...
Import an image map from an HTML text file. This command will parse the first image map in an HTML text file. This is similar to the "Open..." command, but the document title remains "Untitled".
Client-Side Import Image Map URL...
Import an image map from a URL. This command will parse the first image map at the URL. This can be used to load image maps from web sites such as Apple Computer (http://www.apple.com/). Try it!
Export...
Server-Side Image Map File...
Export the image map to a file in server-side image map format.
Preferences...
Show the Preferences dialog.

Preferences are saved in the user's "home" directory (as determined by the Java Virtual Machine) in a file called ".csime.properties". If you don't want preferences saved, press the "Cancel" button.

Quit
Quit the application.

Edit Menu

Undo
Undo is limited to 16 levels.
Map Name...
Specify the map name.
Select All
Select all.
Select None
Select none.
Duplicate Selected
Duplicate the selected area.
Duplicate Selected
Duplicate the selected area.
Delete Selected
Delete the selected area.

Image Menu

Opaque
Make the image opaque.
75% Transparent
Make the image 75% transparent.
50% Transparent
Make the image 50% transparent.
25% Transparent
Make the image 25% transparent.
Invisible
Make the image invisible.

Bookmarks Menu

Browse Bookmarks File...
Load Netscape Bookmarks.html file. Bookmarks can be used to assign links to selected areas. Bookmarks that point to GIF's and JPEG's can be used to load images into the editor.

View Menu

HTML Source...
View HTML text in a dialog. This is what will be saved in the "Save" and "Save As..." commands.

Help Menu

About
Show about dialog. If you executing the Client-Side Image Map Editor in the csime directory, you will see an "About" GIF. Otherwise, you will see "About" text.

Michael Chiang
myc@wwa.com
Last Modified: July 13, 1997